DirectX 진단 도구

Microsoft® DirectX® 진단 도구 설명서에는 다음 항목이 포함되어 있습니다.

  • DirectX 진단 도구
  • 확인 사항
  • DirectX 구성 요소 테스트
  • 기본 주사율 다시 정의


DirectX 진단 도구

Microsoft® DirectX® 진단 도구는 시스템의 DirectX 응용 프로그래밍 인터페이스(API) 구성 요소 및 시스템 드라이버 정보를 제공합니다. 이 도구를 사용하면 소리와 그래픽 출력 및 Microsoft DirectPlay® 서비스 공급자를 테스트할 수 있으며 일부 하드웨어 가속 기능을 사용하지 않도록 설정할 수도 있습니다.

진단 도구를 사용하면 고객 지원 전화를 하는 동안 기술 지원 담당자를 위해 정보를 수집하거나 수집한 정보를 저장하여 전자 메일 메시지에 첨부할 수 있습니다.

정보는 여러 페이지에 걸쳐 나타나며 다음 방법 중 하나를 선택하여 각 페이지로 이동할 수 있습니다.

  • 해당하는 탭을 클릭합니다.
  • 다음 페이지 단추를 클릭합니다.
  • 입력 포커스가 탭 위에 있을 때 왼쪽 또는 오른쪽 화살표 키를 누릅니다.

이 도구에서 테이블을 표시하는 방법을 지정할 수 있습니다. 이를 수행하려면 테이블 행을 정렬할 기준 열을 선택합니다. 그런 다음 선택한 열 맨 위에 있는 머리글 단추를 클릭하면 테이블이 해당 열의 항목을 기준으로 사전순 또는 숫자순으로 정렬됩니다. 정렬 순서를 반대로 하려면 머리글 단추를 다시 한 번 클릭합니다.

모든 정보 저장 단추를 클릭하면 모든 정보를 텍스트 파일로 저장할 수 있습니다.

참고

  • 디스플레이 카드의 메모리 용량 등의 일부 정보는 근사값일 수 있습니다.


확인 사항

Microsoft® DirectX® 응용 프로그램의 실행 중에 문제가 발생한 경우 DirectX 진단 도구를 사용하면 문제의 원인을 찾는 데 도움이 됩니다. 다음과 같은 몇 가지 항목을 확인해야 합니다.

  • 잘못된 버전의 DirectX 구성 요소. DirectX 파일 페이지의 참고 영역에서 베타 및 디버그 파일에 대한 경고 메시지를 확인합니다. 베타 파일은 초기 테스트 버전이므로 판매용 응용 프로그램과 함께 설치해서는 안 됩니다. 디버그 버전 역시 프로그램 개발 중에 사용되므로 베타 파일과 마찬가지로 최종 제품과 함께 설치해서는 안 됩니다. 이 디버그 버전을 설치한 경우에는 응용 프로그램이 일반 정품 버전의 구성 요소에 비해 훨씬 느리게 실행될 수 있습니다.
  • 하드웨어 가속 기능 없음. Microsoft DirectDraw® 또는 Direct3D® 하드웨어 가속을 사용할 수 없는 경우 일부 프로그램이 매우 느리게 실행되거나 전혀 실행되지 않을 수 있습니다. 디스플레이 페이지의 DirectX 기능에서 DirectDraw, Direct3D 또는 AGP 질감 가속이 "사용할 수 없음"으로 표시되어 있는지 확인합니다. 사용할 수 없음으로 표시되어 있으면 하드웨어 업그레이드를 고려해 보십시오.
  • 장치 연결 안 됨. 조이스틱 또는 다른 입력 장치가 올바로 설치되어 있지 않으면 응답하지 않습니다. DirectX 진단 도구의 입력 페이지에서 해당 장치에 대한 설명이 있는지 확인하십시오. 없는 경우 제어판을 사용하여 장치를 추가합니다.
  • 서명되지 않은 드라이버. Microsoft는 서명되지 않은 드라이버가 최신 버전의 DirectX와 제대로 호환되는지 테스트하지 않았습니다. 이러한 드라이버는 해당 구성 요소 페이지에 나열되어 있습니다.

참고: 하드웨어 가속을 지원하는 원격 시스템에서 작업하기 위해 터미널 서비스를 사용하는 경우 DirectX 진단 도구에서 하드웨어 가속 지원을 나타낼 수 있습니다. 그러나 터미널 서비스는 하드웨어 가속을 사용할 수 없으므로 지원하지 않습니다.


DirectX 구성 요소 테스트

시스템에 연결된 각 모니터에서 Microsoft® DirectDraw 및 Direct3D®를 테스트할 수 있습니다. 또한 각 웨이브 출력 장치에서 DirectSound®를 테스트할 수 있고 각 음악 포트에서 DirectMusic®도 테스트할 수 있습니다.

DirectX 기능을 테스트하려면 해당 페이지의 테스트 단추를 클릭하고 나타나는 메세지를 읽은 후에 테스트 단계를 보거나 들어 봅니다. 테스트가 제대로 수행되었는지 확인하는 메시지가 나타날 때까지 각 테스트를 실행합니다. 아니오라고 대답하면 테스트가 더 이상 실행되지 않습니다.

DirectMusic의 경우에는 테스트가 한 번 있습니다. 해당 음악이 제대로 재생되면 확인을 클릭합니다.

사용 가능한 모든 서비스 공급자에서 Microsoft DirectPlay® 기능을 테스트할 수 있습니다.

DirectPlay를 테스트하려면

  1. 네트워크 페이지에서 DirectPlay 테스트를 클릭합니다. DirectPlay 테스트 대화 상자가 나타나면 사용자 이름을 입력하고 서비스 공급자를 선택한 다음 새 세션 만들기를 선택하고 확인을 클릭합니다. 모뎀 연결을 선택한 경우에는 모뎀 연결 대화 상자에서 응답을 클릭하여 모뎀을 자동 응답 모드로 설정합니다.
  2. 첫 번째 컴퓨터와 선택한 연결을 구성할 수 있는 다른 컴퓨터에서 Microsoft DirectX 진단 도구를 실행합니다. DirectPlay 테스트에서 다른 사용자 이름을 입력하고 동일한 서비스 공급자를 선택한 다음 기존 세션에 참가 단추를 클릭하고 확인을 클릭합니다.

    일부 연결 형식의 경우 전화 번호 등의 자세한 정보를 입력하라는 메시지가 나타날 수 있습니다. 로컬 네트워크의 TCP/IP 연결의 경우 입력란을 비워둘 수 있습니다.

  3. 첫 번째 컴퓨터에서 만든 세션의 이름을 포함하는 두 번째 컴퓨터의 세션 목록에서 해당 세션의 이름을 선택한 다음 확인을 클릭합니다.
  4. 이제 두 컴퓨터에 모두 채팅 대화 상자가 표시됩니다. 한 컴퓨터의 입력란에 메시지를 입력하고 보내기를 클릭하면 두 컴퓨터에서 채팅 대화 상자의 스크롤 영역에 메시지가 표시됩니다.


기본 주사율 다시 정의

소리 페이지에서 슬라이더를 움직여 하드웨어 가속 수준을 다르게 설정할 수 있습니다. 설정한 수준은 Microsoft® DirectX® 진단 도구를 닫은 후에도 유지됩니다.

이러한 가속을 사용할 수 있는 경우 Microsoft DirectDraw® 또는 Direct3D®에 대한 하드웨어 가속을 사용할 수 없도록 설정할 수 있습니다. 이를 수행하려면 각 디스플레이 장치의 디스플레이 페이지로 이동하여 사용 안 함 단추를 클릭합니다. 하드웨어 가속을 사용 안 함으로 설정하고 나면 DirectX 진단 도구를 닫은 후에도 응용 프로그램을 사용할 수 없습니다. 하드웨어 가속을 다시 사용할 수 있도록 설정하려면 해당 디스플레이 페이지에서 사용 단추를 클릭합니다.

참고

  • DirectDraw 가속을 사용할 수 없도록 설정하면 Direct3D 가속도 사용할 수 없습니다.

또한 DirectDraw 전체 화면 응용 프로그램에서 설정한 모니터 화면 주사율을 다시 정의할 수도 있습니다. 어떤 응용 프로그램에 디스플레이 문제가 있고 이 응용 프로그램에서 화면 주사율을 잘못 설정했다는 것이 틀림 없을 때만 이 작업을 수행해야 합니다.

화면 주사율을 다시 정의하려면

  1. 기타 도움말 페이지에서 다시 정의 단추를 클릭합니다.
  2. DirectDraw 화면 주사율 다시 정의 대화 상자에서 입력란을 선택하고 사용자의 모니터에 적합한 화면 주사율을 입력합니다.

    이렇게 하면 다시 정의할 값 옵션 단추가 자동으로 선택됩니다.

  3. 확인을 클릭합니다.

화면 주사율 다시 정의를 취소하고 DirectDraw 응용 프로그램에서 기본 화면 주사율을 설정하려면

  1. 기타 도움말 페이지에서 다시 정의 단추를 클릭합니다.
  2. DirectDraw 화면 주사율 다시 정의 대화 상자에서 기본값 옵션 단추를 선택하고 확인을 클릭합니다.